PDA

View Full Version : Login



Louis
25-03-2012, 01:24 PM
I cleared all my cookies, I relogin, click Remember me. But every day, I need to relogin, it's accepted but when it reloads I must relogin again. Always same thing.

Then restart the dance, clear cookies,...

Why?

SweatyCarrot
25-03-2012, 05:17 PM
hmmm what browser are you using?

Zap
25-03-2012, 06:45 PM
Have you tried another computer?

Strong
26-03-2012, 03:45 AM
I had a similar problem but can't quite remember how I resolved the issue.


Check that your browser allows cookies from btwimho.
Check that your browser is remembering your password, for instance in FF you might have the option switched off.
If you have a firewall/internet security software make sure it isn't causing problems.

Louis
26-03-2012, 01:09 PM
hmmm what browser are you using?
Firefox



Have you tried another computer?
Yup, same thing at work and home. Firefox on Mac at home and Firefox on Windoze at work.


I had a similar problem but can't quite remember how I resolved the issue.


Check that your browser allows cookies from btwimho.
Check that your browser is remembering your password, for instance in FF you might have the option switched off.
If you have a firewall/internet security software make sure it isn't causing problems.


No specific settings for cookies. I must go delete them everyday in order to stay logged in from page to page.
Yup, it's enabled
No firewall issues.

Muddy
26-03-2012, 02:13 PM
It's because your fake avatar is sexier than Zap's fake avatar.

Louis
26-03-2012, 09:17 PM
Hmmm, I'm not logged on the main page, but I'm logged in when checking all other pages... WTF?

tsdesigns
27-03-2012, 04:08 AM
Are you logged in to http://btwimho.com/ but not logged in to http://www.btwimho.com/? Or the other way around?

www and non www act as different domains, so set different cookies in the browser.

ps Zap - with a little .htaccess magic you can force the "www." on the front of the domain. (Apparantly) better for SEO too as it doesn't count as duplicate content.

Zap
27-03-2012, 06:21 AM
Are you logged in to http://btwimho.com/ but not logged in to http://www.btwimho.com/? Or the other way around?

www and non www act as different domains, so set different cookies in the browser.

ps Zap - with a little .htaccess magic you can force the "www." on the front of the domain. (Apparantly) better for SEO too as it doesn't count as duplicate content.

Brilliant deduction and probably the cause.
I follow you up to the ".htaccess magic" part. LOL!
I am not great with .htaccess

And Louis, what happens if you use Internet Explorer?

Louis
27-03-2012, 08:56 AM
Are you logged in to btwimho . com but not logged in to www . btwimho . com Or the other way around?

www and non www act as different domains, so set different cookies in the browser.

ps Zap - with a little .htaccess magic you can force the "www ." on the front of the domain. (Apparantly) better for SEO too as it doesn't count as duplicate content.

Yup, logged in on www . btwimho . com and logged out on btwimho . com.


And Louis, what happens if you use Internet Explorer?

I get itchy all over...



To be able to post links or images your post count must be 25 or greater. You currently have 15 posts.

Please remove links from your message, then you will be able to submit your post.

Damn, I'm only replying with quotes....

tsdesigns
27-03-2012, 09:05 AM
Yup, logged in on www . btwimho . com and logged out on btwimho . com.


That'll be the issue then! hmm, wonder why this hasn't come up before.

Zap, if you like I'll sort the .htaccess file for you =)


I get itchy all over...

http://browseryoulovedtohate.com/

I have to say, IE's getting better...but it's still nowhere near as good as the rest, way too many restrictions in their development process that stop the IE team from making the browser great. It's just what people use as it comes with windows...

Zap
27-03-2012, 09:30 AM
Zap, if you like I'll sort the .htaccess file for you =)


If you can, that would be awesome.
Thanks Dude.

Here's what's in there currently...

RewriteEngine on
SetEnvIfNoCase User-Agent "^Missigua Locator" bad_bot
#SetEnvIfNoCase User-Agent "^PEAR HTTP_Request class" bad_bot
SetEnvIfNoCase User-Agent "^Java/1.4.1" bad_bot
SetEnvIfNoCase User-Agent "^Java/1.5.0" bad_bot
SetEnvIfNoCase User-Agent "^libwww-perl" bad_bot
SetEnvIfNoCase User-Agent "^Wells Search II" bad_bot
SetEnvIfNoCase User-Agent "^psycheclone" bad_bot
SetEnvIfNoCase User-Agent "^WEP Search 00" bad_bot
SetEnvIfNoCase User-Agent "ia_archiver" bad_bot
deny from env=bad_bot

RewriteCond %{HTTP_REFERER} !^http://btwimho.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://btwimho.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.btwimho.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.btwimho.com$ [NC]
RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]

tsdesigns
27-03-2012, 09:44 AM
This should work:

Just remove the spaces from the URL (it kept turning it into a link, had to add spaces)


RewriteEngine on
SetEnvIfNoCase User-Agent "^Missigua Locator" bad_bot
#SetEnvIfNoCase User-Agent "^PEAR HTTP_Request class" bad_bot
SetEnvIfNoCase User-Agent "^Java/1.4.1" bad_bot
SetEnvIfNoCase User-Agent "^Java/1.5.0" bad_bot
SetEnvIfNoCase User-Agent "^libwww-perl" bad_bot
SetEnvIfNoCase User-Agent "^Wells Search II" bad_bot
SetEnvIfNoCase User-Agent "^psycheclone" bad_bot
SetEnvIfNoCase User-Agent "^WEP Search 00" bad_bot
SetEnvIfNoCase User-Agent "ia_archiver" bad_bot
deny from env=bad_bot

RewriteCond %{HTTP_REFERER} !^http://btwimho.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://btwimho.com$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.btwimho.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.btwimho.com$ [NC]
RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]

RewriteCond %{HTTP_HOST} ^www . btwimho.com[NC] #remove spaces between www . btwimho
RewriteRule ^(.*)$ http://www.btwimho.com/$1 [L,R=301]

Muddy
27-03-2012, 09:57 AM
This will work too. :sqbiggrin:



Options +FollowSymLinks
RewriteEngine On
RewriteCond %{HTTP_HOST} ^btwimho\.com$ [NC]
RewriteRule ^(.*)$ http://www.btwimho.com/$1 [R=301,L]

Muddy
27-03-2012, 09:59 AM
oops...LOL...You have that Nick. Good deal!

Zap
27-03-2012, 10:08 AM
All right Louis.
You've got the greatest minds in the universe solving the problem right here.

How is it now?

tsdesigns
27-03-2012, 10:14 AM
All right Louis.
You've got the greatest minds in the universe solving the problem right here.

haha I don't know about that...I just do this too often on client sites I know what to do! :p

Seems to be working for me anyway, so should be fine all round! :D

Speaking of client sites, I should probably get back to work...

Louis
27-03-2012, 10:24 AM
btwimho . com gets redirected to www . btwimho . com and it seems all good!